[US] Laserfiche Cloud pages under the Home section may be unavailable for users

Incident Report for Laserfiche

Resolved

The issue has been resolved.
Posted Apr 02, 2026 - 13:03 PDT

Monitoring

A change has been implemented which should mitigate the issue. Users will need to log out of Laserfiche Cloud, clear their recent browser cache, and then log back in.
Posted Apr 02, 2026 - 11:09 PDT

Investigating

We are investigating an issue where users may not see anything when viewing pages under the Home section.
Posted Apr 02, 2026 - 10:39 PDT
This incident affected: US (Process Automation).