[US] - Users may experience slower performance in Workflow processing

Incident Report for Laserfiche

Resolved

The issue has been addressed.
Posted Aug 21, 2026 - 11:02 PDT

Investigating

We are currently investigating a performance issue that may cause Workflow activities to take longer than normal to complete.
Posted Aug 21, 2026 - 09:53 PDT
This incident affected: US (Process Automation).