Repository outage

Incident Report for Laserfiche

Resolved

We've confirmed that all repositories are accessible again.
Posted Jun 24, 2025 - 19:15 PDT

Monitoring

We have implemented a fix. We expect all repositories to be available again.
Posted Jun 24, 2025 - 19:01 PDT

Investigating

We are aware of issues accessing Laserfiche repositories. We are actively investigating.
Posted Jun 24, 2025 - 18:38 PDT
This incident affected: US (Repository Service), Canada (Repository Service), and EMEA (Repository Service).