Laserfiche Cloud US - Process Automation site is unavailable
Incident Report for Laserfiche
Resolved
This incident has been resolved.
Posted May 03, 2022 - 17:36 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 03, 2022 - 15:05 PDT
Investigating
We are investigating an issue where the Process Automation site is currently unavailable.
Posted May 03, 2022 - 14:50 PDT
This incident affected: US (Process Automation).