[US] - Lookups in Forms business processes may be slow to complete
Incident Report for Laserfiche
Resolved
The issue has been resolved.
Posted Oct 24, 2023 - 13:47 PDT
Monitoring
The issue has been mitigated and we will continue monitoring the situation.
Posted Oct 24, 2023 - 11:35 PDT
This incident affected: US (Forms).