[US][CA] - Some customers may experience a delay in Workflow performance

Incident Report for Laserfiche

Resolved

The issue has been resolved.
Posted Jan 09, 2026 - 12:28 PST

Monitoring

Mitigation steps have been taken and Workflow processing performance has improved. We continue to monitor the results.
Posted Jan 09, 2026 - 10:11 PST

Update

We are continuing to investigate this issue.
Posted Jan 09, 2026 - 07:40 PST

Investigating

We are investigating reported slowness with Workflow activity processing times.
Posted Jan 09, 2026 - 07:02 PST
This incident affected: US (Process Automation) and Canada (Process Automation).