Steps have been taken to mitigate the issue and access to the applications should be restored. We will continue monitoring the situation.
Posted Feb 23, 2024 - 13:46 PST
Investigating
We are currently investigating an issue in the Laserfiche Cloud US region where users may see an error when trying to access their repository or trying to access Process Automation.
Posted Feb 23, 2024 - 13:23 PST
This incident affected: US (Repository Service, Process Automation).