[US] - Users may experience intermittent performance issues navigating Laserfiche Cloud Process Automation sites

Incident Report for Laserfiche

Resolved

The issue has been resolved.
Posted Aug 05, 2026 - 13:10 PDT

Monitoring

The performance has stabilized and we will continue monitoring the system.
Posted Aug 05, 2026 - 11:36 PDT

Investigating

The issue is being investigated.
Posted Aug 05, 2026 - 08:59 PDT
This incident affected: US (Process Automation).