[CA] - Business Process forms lookup rules may be slow to retrieve results

Incident Report for Laserfiche

Resolved

The issue has been resolved.
Posted Apr 16, 2026 - 14:59 PDT

Monitoring

The issue has been mitigated. We will continue monitoring the results.
Posted Apr 16, 2026 - 13:58 PDT

Investigating

We are investigating an issue where Laserfiche Cloud Canada users that are filling out forms with lookup rules may encounter slowness when retrieving results.
Posted Apr 16, 2026 - 13:01 PDT
This incident affected: Canada (Forms).