Connection issues to https://support.laserfiche.com, https://orders.laserfiche.com and other sites
Incident Report for Laserfiche
Resolved
The issue has been resolved and connectivity to Laserfiche sites should be restored.
Posted Nov 22, 2023 - 10:17 PST
Monitoring
The issue of access to some Laserfiche sites are related to Internet routing and is currently being investigated. Services may be intermittent until the issue is fully resolved by services providers. Laserfiche is currently monitoring this and will provide an update once the issue is fully resolved.
Posted Nov 22, 2023 - 10:02 PST
Investigating
We are investigating connection issues that some users may have when trying to reach https://support.laserfiche.com, https://orders.laserfiche.com and other Laserfiche sites. At this time, we do not have an ETA for when the issue may be resolved.

Note: Laserfiche Cloud is not affected by this issue.
Posted Nov 22, 2023 - 09:28 PST