[US] - Issue signing into Laserfiche Cloud and accessing Account Administration
Incident Report for Laserfiche
Resolved
The issue has been resolved
Posted Jun 16, 2022 - 09:12 PDT
Investigating
We are currently investigating an issue where some users are unable to log into Laserfiche Cloud and accessing their Account Administration page.
Posted Jun 16, 2022 - 08:46 PDT