[US] - Repository service is unavailable for some customers
Incident Report for Laserfiche
Resolved
This incident has been resolved.
Posted May 16, 2022 - 10:52 PDT
Investigating
We are investigating partial service unavailability of the repository impacting some customers.
Posted May 16, 2022 - 09:39 PDT
This incident affected: US (Repository Service).